<!DOCTYPE html>
<html lang="en-US">
<head>
    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <link rel="profile" href="http://gmpg.org/xfn/11">
    <link rel="pingback" href="https://grasslandtimes.com/xmlrpc.php">
    <title>Rodrigo Duterte and Kim Jong-un impersonators cause a stir &#8211; Grassland Times</title>
        <style type="text/css">
                                .inner-header-overlay,
                    .hero-slider.overlay .slide-item .bg-image:before {
                        background: #042738;
                        filter: alpha(opacity=65);
                        opacity: 0.65;
                    }
                    </style>

    
<!-- Social Warfare v3.3.3 https://warfareplugins.com --><style>@font-face {font-family: "sw-icon-font";src:url("https://grasslandtimes.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=3.3.3");src:url("https://grasslandtimes.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=3.3.3#iefix") format("embedded-opentype"),url("https://grasslandtimes.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.woff?ver=3.3.3") format("woff"),
	url("https://grasslandtimes.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.ttf?ver=3.3.3") format("truetype"),url("https://grasslandtimes.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.svg?ver=3.3.3#1445203416") format("svg");font-weight: normal;font-style: normal;}</style>
<!-- Social Warfare v3.3.3 https://warfareplugins.com -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Grassland Times &raquo; Feed" href="https://grasslandtimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Grassland Times &raquo; Comments Feed" href="https://grasslandtimes.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Grassland Times &raquo; Rodrigo Duterte and Kim Jong-un impersonators cause a stir Comments Feed" href="https://grasslandtimes.com/rodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir/2461/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/grasslandtimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.9"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ --><script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='fontawesome-css-css'  href='https://grasslandtimes.com/wp-content/plugins/accesspress-social-counter/css/font-awesome.min.css?ver=1.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='apsc-frontend-css-css'  href='https://grasslandtimes.com/wp-content/plugins/accesspress-social-counter/css/frontend.css?ver=1.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://grasslandtimes.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='wwm_social_share_style-css'  href='https://grasslandtimes.com/wp-content/plugins/wwm-social-share-on-image-hover/css/wwm_custom.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='awpa-wp-post-author-style-css'  href='https://grasslandtimes.com/wp-content/plugins/wp-post-author//assets/css/awpa-frontend-style.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='social_warfare-css'  href='https://grasslandtimes.com/wp-content/plugins/social-warfare/assets/css/style.min.css?ver=3.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-slick-css'  href='https://grasslandtimes.com/wp-content/themes/perfect-magazine/assets/libraries/slick/css/slick.min.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='ionicons-css'  href='https://grasslandtimes.com/wp-content/themes/perfect-magazine/assets/libraries/ionicons/css/ionicons.min.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://grasslandtimes.com/wp-content/themes/perfect-magazine/assets/libraries/bootstrap/css/bootstrap.min.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css'  href='https://grasslandtimes.com/wp-content/themes/perfect-magazine/assets/libraries/magnific-popup/magnific-popup.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='perfect-magazine-style-css'  href='https://grasslandtimes.com/wp-content/themes/newsliner/style.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='perfect-magazine-google-fonts-css'  href='//fonts.googleapis.com/css?family=Source%20Sans%20Pro:400,400i,600,600i|Playfair%20Display:400,400i,700,700i,900&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='recent-posts-widget-with-thumbnails-public-style-css'  href='https://grasslandtimes.com/wp-content/plugins/recent-posts-widget-with-thumbnails/public.css?ver=6.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='newsliner-style-parent-css'  href='https://grasslandtimes.com/wp-content/themes/perfect-magazine/style.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='newsliner-css'  href='https://grasslandtimes.com/wp-content/themes/newsliner/assets/css/custom.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://grasslandtimes.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.6.1' type='text/css' media='all' />
<script type='text/javascript' src='https://grasslandtimes.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://grasslandtimes.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://grasslandtimes.com/wp-content/plugins/wwm-social-share-on-image-hover/js/wwm_custom.js?ver=4.9.9'></script>
<link rel='https://api.w.org/' href='https://grasslandtimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://grasslandtimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://grasslandtimes.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Maroon 5 Slammed performance &#8216;cop-out&#8217; by Colin Kaepernick&#8217;s attorney' href='https://grasslandtimes.com/maroon-5-slammed-performance-cop-out-by-colin-kaepernicks-attorney/2468/' />
<link rel='next' title='Save Yourself from Choking with This Trick' href='https://grasslandtimes.com/save-yourself-from-choking-with-this-trick/2462/' />
<meta name="generator" content="WordPress 4.9.9" />
<link rel="canonical" href="https://grasslandtimes.com/rodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir/2461/" />
<link rel='shortlink' href='https://wp.me/p9HC3U-DH' />
		<!-- Custom Logo: hide header text -->
		<style id="custom-logo-css" type="text/css">
			.site-title, .site-description {
				position: absolute;
				clip: rect(1px, 1px, 1px, 1px);
			}
		</style>
	<link rel="alternate" type="application/json+oembed" href="https://grasslandtimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgrasslandtimes.com%2Frodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir%2F2461%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://grasslandtimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgrasslandtimes.com%2Frodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir%2F2461%2F&#038;format=xml" />
<style type="text/css"> .enews .screenread {
	height: 1px;
    left: -1000em;
    overflow: hidden;
    position: absolute;
    top: -1000em;
    width: 1px; } </style>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style>
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Rodrigo Duterte and Kim Jong-un impersonators cause a stir" />
<meta property="og:url" content="https://grasslandtimes.com/rodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir/2461/" />
<meta property="og:description" content="In pictures: Rodrigo Duterte and Kim Jong-un impersonators cause a stir This now seems like as if Rodrigo Duterte being the Philippine President and Kim Jong-Un the North Korean leader have been ou…" />
<meta property="article:published_time" content="2019-02-05T10:06:23+00:00" />
<meta property="article:modified_time" content="2019-02-05T10:06:23+00:00" />
<meta property="og:site_name" content="Grassland Times" />
<meta property="og:image" content="https://grasslandtimes.com/wp-content/uploads/2019/02/Rodrigo-Duterte-and-Kim-Jong-un-impersonators-cause-a-stir.jpg" />
<meta property="og:image:width" content="850" />
<meta property="og:image:height" content="450" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@JustNowBulletin" />
<meta name="twitter:text:title" content="Rodrigo Duterte and Kim Jong-un impersonators cause a stir" />
<meta name="twitter:image" content="https://grasslandtimes.com/wp-content/uploads/2019/02/Rodrigo-Duterte-and-Kim-Jong-un-impersonators-cause-a-stir.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->

<!-- BEGIN ExactMetrics v5.3.5 Universal Analytics - https://exactmetrics.com/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-120025489-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END ExactMetrics Universal Analytics -->
<style id="tt-easy-google-font-styles" type="text/css">p { }
h1 { }
h2 { }
h3 { }
h4 { }
h5 { }
h6 { }
</style></head>
<body class="post-template-default single single-post postid-2461 single-format-standard wp-custom-logo static-page group-blog left-sidebar ">

<!-- full-screen-layout/boxed-layout -->

<div id="page" class="site boxed-layout ">
    <a class="skip-link screen-reader-text" href="#main">Skip to content</a>
    <header id="masthead" class="site-header" role="banner">

                    <div class="news-ticker">
                <div class="container">
                    <div class="row">
                        <div class="col-sm-12">
                            <div class="news-scroller">
                                                                                                            <div class="news-scroller-item">
                                                <div class="featured-wrapper">
                                                    <div class="featured-wrapper-child featured-img-wrapper">
                                                        <a href="https://grasslandtimes.com/3750-more-troops-sent-to-mexico-border-by-pentagon/2465/" class="bg-image ticker-bg-image">
                                                            <img src="https://grasslandtimes.com/wp-content/uploads/2019/02/3750-More-Troops-Sent-To-Mexico-Border-by-Pentagon-300x159.jpg">
                                                        </a>
                                                    </div>
                                                    <header class="featured-wrapper-child entry-header">
                                                        <div class="entry-header">
                                                            <h3 class="entry-title">
                                                                <a href="https://grasslandtimes.com/3750-more-troops-sent-to-mexico-border-by-pentagon/2465/">3,750 More Troops Sent To Mexico Border by Pentagon</a>
                                                            </h3>
                                                        </div>
                                                        <div class="entry-footer">
                                                            <span class="posted-on"> <a href="https://grasslandtimes.com/3750-more-troops-sent-to-mexico-border-by-pentagon/2465/" rel="bookmark"><time class="entry-date published updated" datetime="2019-02-05T10:07:58+00:00">February 5, 2019</time></a></span>                                                        </div>
                                                    </header>
                                                </div>
                                            </div>
                                                                                    <div class="news-scroller-item">
                                                <div class="featured-wrapper">
                                                    <div class="featured-wrapper-child featured-img-wrapper">
                                                        <a href="https://grasslandtimes.com/nissans-choice-for-new-x-trail-car-is-japan-instead-of-uk/2464/" class="bg-image ticker-bg-image">
                                                            <img src="https://grasslandtimes.com/wp-content/uploads/2019/02/Nissans-Choice-For-New-X-Trail-Car-is-Japan-instead-of-UK-300x159.jpg">
                                                        </a>
                                                    </div>
                                                    <header class="featured-wrapper-child entry-header">
                                                        <div class="entry-header">
                                                            <h3 class="entry-title">
                                                                <a href="https://grasslandtimes.com/nissans-choice-for-new-x-trail-car-is-japan-instead-of-uk/2464/">Nissan&#8217;s Choice For New X-Trail Car is Japan instead of UK</a>
                                                            </h3>
                                                        </div>
                                                        <div class="entry-footer">
                                                            <span class="posted-on"> <a href="https://grasslandtimes.com/nissans-choice-for-new-x-trail-car-is-japan-instead-of-uk/2464/" rel="bookmark"><time class="entry-date published updated" datetime="2019-02-05T10:07:43+00:00">February 5, 2019</time></a></span>                                                        </div>
                                                    </header>
                                                </div>
                                            </div>
                                                                                    <div class="news-scroller-item">
                                                <div class="featured-wrapper">
                                                    <div class="featured-wrapper-child featured-img-wrapper">
                                                        <a href="https://grasslandtimes.com/polar-vortex-brought-number-of-problems-in-usa/2446/" class="bg-image ticker-bg-image">
                                                            <img src="https://grasslandtimes.com/wp-content/uploads/2019/02/Polar-Vertix-300x159.jpg">
                                                        </a>
                                                    </div>
                                                    <header class="featured-wrapper-child entry-header">
                                                        <div class="entry-header">
                                                            <h3 class="entry-title">
                                                                <a href="https://grasslandtimes.com/polar-vortex-brought-number-of-problems-in-usa/2446/">Polar Vortex Brought Number of Problems in USA</a>
                                                            </h3>
                                                        </div>
                                                        <div class="entry-footer">
                                                            <span class="posted-on"> <a href="https://grasslandtimes.com/polar-vortex-brought-number-of-problems-in-usa/2446/" rel="bookmark"><time class="entry-date published updated" datetime="2019-02-03T08:01:09+00:00">February 3, 2019</time></a></span>                                                        </div>
                                                    </header>
                                                </div>
                                            </div>
                                                                                    <div class="news-scroller-item">
                                                <div class="featured-wrapper">
                                                    <div class="featured-wrapper-child featured-img-wrapper">
                                                        <a href="https://grasslandtimes.com/james-ingram-dies-at-66-grammy-winning-chart-topping-rb-singer/2445/" class="bg-image ticker-bg-image">
                                                            <img src="https://grasslandtimes.com/wp-content/uploads/2019/02/James-Ingram-300x159.jpg">
                                                        </a>
                                                    </div>
                                                    <header class="featured-wrapper-child entry-header">
                                                        <div class="entry-header">
                                                            <h3 class="entry-title">
                                                                <a href="https://grasslandtimes.com/james-ingram-dies-at-66-grammy-winning-chart-topping-rb-singer/2445/">James Ingram ,Dies at 66, Grammy-Winning &#038; Chart-Topping R&#038;B Singer,</a>
                                                            </h3>
                                                        </div>
                                                        <div class="entry-footer">
                                                            <span class="posted-on"> <a href="https://grasslandtimes.com/james-ingram-dies-at-66-grammy-winning-chart-topping-rb-singer/2445/" rel="bookmark"><time class="entry-date published updated" datetime="2019-02-03T08:00:33+00:00">February 3, 2019</time></a></span>                                                        </div>
                                                    </header>
                                                </div>
                                            </div>
                                                                                    <div class="news-scroller-item">
                                                <div class="featured-wrapper">
                                                    <div class="featured-wrapper-child featured-img-wrapper">
                                                        <a href="https://grasslandtimes.com/star-from-empire-jussie-smollet-tells-cops-about-his-attackers/2442/" class="bg-image ticker-bg-image">
                                                            <img src="https://grasslandtimes.com/wp-content/uploads/2019/02/Jussie-Smollet-300x159.jpg">
                                                        </a>
                                                    </div>
                                                    <header class="featured-wrapper-child entry-header">
                                                        <div class="entry-header">
                                                            <h3 class="entry-title">
                                                                <a href="https://grasslandtimes.com/star-from-empire-jussie-smollet-tells-cops-about-his-attackers/2442/">Star from &#8220;Empire&#8221; Jussie Smollet Tells Cops About His Attackers</a>
                                                            </h3>
                                                        </div>
                                                        <div class="entry-footer">
                                                            <span class="posted-on"> <a href="https://grasslandtimes.com/star-from-empire-jussie-smollet-tells-cops-about-his-attackers/2442/" rel="bookmark"><time class="entry-date published updated" datetime="2019-02-03T07:59:42+00:00">February 3, 2019</time></a></span>                                                        </div>
                                                    </header>
                                                </div>
                                            </div>
                                                                                    <div class="news-scroller-item">
                                                <div class="featured-wrapper">
                                                    <div class="featured-wrapper-child featured-img-wrapper">
                                                        <a href="https://grasslandtimes.com/insulin-cost-per-patient-doubles-in-u-s-study/2399/" class="bg-image ticker-bg-image">
                                                            <img src="https://grasslandtimes.com/wp-content/uploads/2019/01/US-insulin-Costs-300x159.jpg">
                                                        </a>
                                                    </div>
                                                    <header class="featured-wrapper-child entry-header">
                                                        <div class="entry-header">
                                                            <h3 class="entry-title">
                                                                <a href="https://grasslandtimes.com/insulin-cost-per-patient-doubles-in-u-s-study/2399/">Insulin Cost Per Patient Doubles in U.S. : Study</a>
                                                            </h3>
                                                        </div>
                                                        <div class="entry-footer">
                                                            <span class="posted-on"> <a href="https://grasslandtimes.com/insulin-cost-per-patient-doubles-in-u-s-study/2399/" rel="bookmark"><time class="entry-date published updated" datetime="2019-01-28T08:33:00+00:00">January 28, 2019</time></a></span>                                                        </div>
                                                    </header>
                                                </div>
                                            </div>
                                                                                    <div class="news-scroller-item">
                                                <div class="featured-wrapper">
                                                    <div class="featured-wrapper-child featured-img-wrapper">
                                                        <a href="https://grasslandtimes.com/eat-more-plants-but-less-meat-says-canadas-food-guide-2019/2394/" class="bg-image ticker-bg-image">
                                                            <img src="https://grasslandtimes.com/wp-content/uploads/2019/01/Canada-Food-Guide-300x159.jpg">
                                                        </a>
                                                    </div>
                                                    <header class="featured-wrapper-child entry-header">
                                                        <div class="entry-header">
                                                            <h3 class="entry-title">
                                                                <a href="https://grasslandtimes.com/eat-more-plants-but-less-meat-says-canadas-food-guide-2019/2394/">Eat More Plants but Less Meat  ~ Says Canada&#8217;s Food Guide 2019</a>
                                                            </h3>
                                                        </div>
                                                        <div class="entry-footer">
                                                            <span class="posted-on"> <a href="https://grasslandtimes.com/eat-more-plants-but-less-meat-says-canadas-food-guide-2019/2394/" rel="bookmark"><time class="entry-date published updated" datetime="2019-01-28T08:30:58+00:00">January 28, 2019</time></a></span>                                                        </div>
                                                    </header>
                                                </div>
                                            </div>
                                                                                    <div class="news-scroller-item">
                                                <div class="featured-wrapper">
                                                    <div class="featured-wrapper-child featured-img-wrapper">
                                                        <a href="https://grasslandtimes.com/meteorite-supposed-to-hit-moon-last-monday-lunar-eclipse-update/2392/" class="bg-image ticker-bg-image">
                                                            <img src="https://grasslandtimes.com/wp-content/uploads/2019/01/Lunar-Eclipse-300x159.jpg">
                                                        </a>
                                                    </div>
                                                    <header class="featured-wrapper-child entry-header">
                                                        <div class="entry-header">
                                                            <h3 class="entry-title">
                                                                <a href="https://grasslandtimes.com/meteorite-supposed-to-hit-moon-last-monday-lunar-eclipse-update/2392/">Meteorite Supposed To Hit Moon Last Monday:  Lunar Eclipse Update</a>
                                                            </h3>
                                                        </div>
                                                        <div class="entry-footer">
                                                            <span class="posted-on"> <a href="https://grasslandtimes.com/meteorite-supposed-to-hit-moon-last-monday-lunar-eclipse-update/2392/" rel="bookmark"><time class="entry-date published updated" datetime="2019-01-28T08:29:21+00:00">January 28, 2019</time></a></span>                                                        </div>
                                                    </header>
                                                </div>
                                            </div>
                                                                    </div>
                        </div>
                    </div>
                </div>
            </div>
        
        <div class="top-bar">
            <div class="container-fluid">
                <div class="row">
                    <div class="col-sm-8 col-xs-12">
                        <div class="tm-social-share">
                                                        <div class="social-icons ">
                                <div class="menu-main-menu-container"><ul id="social-menu" class=""><li id="menu-item-1695" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1695"><a href="https://grasslandtimes.com/blog/"><span class="screen-reader-text">Blog</span></a></li>
<li id="menu-item-1696" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1696"><a href="https://grasslandtimes.com/contact/"><span class="screen-reader-text">Contact Us</span></a></li>
<li id="menu-item-1697" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1697"><a href="https://grasslandtimes.com/privacy-policy/"><span class="screen-reader-text">Privacy Policy</span></a></li>
<li id="menu-item-1698" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1698"><a href="https://grasslandtimes.com/submit-news/"><span class="screen-reader-text">Submit News</span></a></li>
<li id="menu-item-1699" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1699"><a href="https://grasslandtimes.com/terms-and-conditions/"><span class="screen-reader-text">Terms and Conditions</span></a></li>
</ul></div>                                <span aria-hidden="true" class="stretchy-nav-bg secondary-bgcolor"></span>
                            </div>
                        </div>
                    </div>
                    <div class="col-sm-4 col-xs-12 pull-right icon-search">
                        <form role="search" method="get" class="search-form" action="https://grasslandtimes.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>                    </div>
                </div>
            </div>
        </div>
        <div class="header-middle">
            <div class="container">
                <div class="row">
                    <div class="col-sm-12">
                        <div class="site-branding">
                                                            <span class="site-title secondary-font">
                                <a href="https://grasslandtimes.com/" rel="home">
                                    Grassland Times                                </a>
                            </span>
                            <a href="https://grasslandtimes.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="300" height="86" src="https://grasslandtimes.com/wp-content/uploads/2018/07/logo-7-300x86.png" class="custom-logo" alt="grassland logo" itemprop="logo" /></a>                                <p class="site-description"><span>Daily Times</span></p>
                                                    </div>
                    </div>
                </div>
            </div>
        </div>
        <div class="navigation-area">
            <div class="container">
                <div class="row">
                    <nav class="main-navigation" role="navigation">
                            <span class="toggle-menu" aria-controls="primary-menu" aria-expanded="false">
                                 <span class="screen-reader-text">
                                    Primary Menu                                </span>
                                <i class="ham"></i>
                            </span>

                        <div class="menu"><ul id="primary-menu" class="menu"><li id="menu-item-22" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22"><a href="https://grasslandtimes.com/category/breaking-news/">Breaking News</a></li>
<li id="menu-item-23" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-23"><a href="https://grasslandtimes.com/category/business/">Business</a>
<ul class="sub-menu">
	<li id="menu-item-28" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28"><a href="https://grasslandtimes.com/category/finance/">Finance</a></li>
</ul>
</li>
<li id="menu-item-26" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-26"><a href="https://grasslandtimes.com/category/entertainment/">Entertainment</a>
<ul class="sub-menu">
	<li id="menu-item-27" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27"><a href="https://grasslandtimes.com/category/fashion/">Fashion</a></li>
	<li id="menu-item-24" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://grasslandtimes.com/category/celebrity/">Celebrity</a></li>
</ul>
</li>
<li id="menu-item-31" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-31"><a href="https://grasslandtimes.com/category/health-fitness/">Health and Fitness</a>
<ul class="sub-menu">
	<li id="menu-item-29" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29"><a href="https://grasslandtimes.com/category/food/">Food</a></li>
</ul>
</li>
<li id="menu-item-37" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37"><a href="https://grasslandtimes.com/category/politics/">Politics</a></li>
<li id="menu-item-33" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-33"><a href="https://grasslandtimes.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-25" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25"><a href="https://grasslandtimes.com/category/cricket/">Cricket</a></li>
</ul>
</li>
<li id="menu-item-34" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-34"><a href="https://grasslandtimes.com/category/tech/">Technology</a>
<ul class="sub-menu">
	<li id="menu-item-32" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32"><a href="https://grasslandtimes.com/category/marketing/">Marketing</a></li>
</ul>
</li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35"><a href="https://grasslandtimes.com/category/travel-tourism/">Travel &#038; Tourism</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-36"><a href="https://grasslandtimes.com/category/world-news/">World News</a></li>
</ul></div>                    </nav><!-- #site-navigation -->
                </div>
            </div>
        </div>
    </header>
    <!-- #masthead -->

            <div class="wrapper page-inner-title inner-banner primary-bgcolor data-bg " data-background="">
            <header class="entry-header">
                <div class="container-fluid">
                    <div class="row">
                        <div class="col-md-12">
                                                            <h1 class="entry-title">Rodrigo Duterte and Kim Jong-un impersonators cause a stir</h1>                                                                    <header class="entry-header">
                                        <div class="entry-meta entry-inner">
                                            <span class="posted-on">Published on : <a href="https://grasslandtimes.com/rodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir/2461/" rel="bookmark"><time class="entry-date published updated" datetime="2019-02-05T10:06:23+00:00">February 5, 2019</time></a></span><span class="byline"> Published by : <span class="author vcard"><a class="url fn n" href="https://grasslandtimes.com/author/authoramy/">Amy J Madison</a></span></span>                                        </div><!-- .entry-meta -->
                                    </header><!-- .entry-header -->
                                                        </div>
                    </div>
                </div>
            </header><!-- .entry-header -->
            <div class="bg-overlay"></div>
        </div>
        <div class="breadcrumb-wrapper">
            <div class="container">
                <div class="row">
                    <div class="col-md-12"></div><!-- .container -->                </div>
            </div>
        </div>

        
    <div id="content" class="site-content">
    <div id="primary" class="content-area">
        <main id="main" class="site-main" role="main">

            
<article id="post-2461" class="post-2461 post type-post status-publish format-standard has-post-thumbnail hentry category-world-news tag-kim-jong-un tag-korea tag-rodrigo-duterte">
    
        <div class="entry-content">
            <div class='image-full'><img width="850" height="450" src="https://grasslandtimes.com/wp-content/uploads/2019/02/Rodrigo-Duterte-and-Kim-Jong-un-impersonators-cause-a-stir.jpg" class="attachment-full size-full wp-post-image" alt="Rodrigo Duterte and Kim Jong-un" srcset="https://grasslandtimes.com/wp-content/uploads/2019/02/Rodrigo-Duterte-and-Kim-Jong-un-impersonators-cause-a-stir.jpg 850w, https://grasslandtimes.com/wp-content/uploads/2019/02/Rodrigo-Duterte-and-Kim-Jong-un-impersonators-cause-a-stir-300x159.jpg 300w, https://grasslandtimes.com/wp-content/uploads/2019/02/Rodrigo-Duterte-and-Kim-Jong-un-impersonators-cause-a-stir-768x407.jpg 768w" sizes="(max-width: 850px) 100vw, 850px" /></div><div class="entry-content" data-initials="">            <div class="grass-before-content" style="float: left; " id="grass-1748484110"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><!-- Front page - 1 (thewomenproject.com) --><ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3908513305207951" data-ad-slot="5468101429" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div class="swp_social_panel swp_horizontal_panel  swp_flat_fresh  swp_default_full_color swp_individual_full_color swp_other_full_color  scale-100  scale-" data-min-width="1100" data-float-color="#ffffff" data-float="bottom" data-float-mobile="" style=""><div class="nc_tweetContainer swp_facebook" data-network="facebook"><a rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fgrasslandtimes.com%2Frodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir%2F2461%2F" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fgrasslandtimes.com%2Frodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir%2F2461%2F" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_twitter" data-network="twitter"><a rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=Rodrigo+Duterte+and+Kim+Jong-un+impersonators+cause+a+stir&amp;url=https%3A%2F%2Fgrasslandtimes.com%2Frodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir%2F2461%2F" data-link="https://twitter.com/intent/tweet?text=Rodrigo+Duterte+and+Kim+Jong-un+impersonators+cause+a+stir&amp;url=https%3A%2F%2Fgrasslandtimes.com%2Frodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir%2F2461%2F" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_google_plus" data-network="google_plus"><a rel="nofollow noreferrer noopener" target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fgrasslandtimes.com%2Frodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir%2F2461%2F" data-link="https://plus.google.com/share?url=https%3A%2F%2Fgrasslandtimes.com%2Frodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir%2F2461%2F" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_google_plus_icon"></i><span class="swp_share">+1</span></span></span></span></a></div><div class="nc_tweetContainer swp_linkedin" data-network="linkedin"><a rel="nofollow noreferrer noopener" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fgrasslandtimes.com%2Frodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir%2F2461%2F" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fgrasslandtimes.com%2Frodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir%2F2461%2F" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_linkedin_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_pinterest" data-network="pinterest"><a rel="nofollow noreferrer noopener" class="nc_tweet noPop" onclick="var e=document.createElement('script');
						   e.setAttribute('type','text/javascript');
						   e.setAttribute('charset','UTF-8');
						   e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);
						   document.body.appendChild(e);
						"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_pinterest_icon"></i><span class="swp_share">Pin</span></span></span></span></a></div><div class="nc_tweetContainer total_shares total_sharesalt"><span class="swp_count ">0 <span class="swp_label">Shares</span></span></div></div><p><strong>In pictures: Rodrigo Duterte and Kim Jong-un impersonators cause a stir</strong></p>
<p>This now seems like as if Rodrigo Duterte being the Philippine President and Kim Jong-Un the North Korean leader have been out on the Hong Kong’s street and they have been posing for the pictures and also toasting each other while having a dinner containing fried chicken.  But if is looked forward on a closer inspection, this situation turned out being the pair which in fact is a couple of some impersonators.  Here you meet the guys who now go by the name of Howard X and Cresencio Extreme.</p><div class="grass-content" style="text-align: center; " id="grass-1131819417"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><!-- bo in post --><ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-3908513305207951" data-ad-slot="2872983825"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p><strong> </strong></p>
<p><img class="alignnone size-medium wp-image-2476" src="https://grasslandtimes.com/wp-content/uploads/2019/02/in-picture-6-300x169.jpg" alt="" width="300" height="169" srcset="https://grasslandtimes.com/wp-content/uploads/2019/02/in-picture-6-300x169.jpg 300w, https://grasslandtimes.com/wp-content/uploads/2019/02/in-picture-6-768x432.jpg 768w, https://grasslandtimes.com/wp-content/uploads/2019/02/in-picture-6.jpg 976w" sizes="(max-width: 300px) 100vw, 300px"><img class="alignnone size-medium wp-image-2473" src="https://grasslandtimes.com/wp-content/uploads/2019/02/in-picrture-5-300x169.jpg" alt="" width="300" height="169" srcset="https://grasslandtimes.com/wp-content/uploads/2019/02/in-picrture-5-300x169.jpg 300w, https://grasslandtimes.com/wp-content/uploads/2019/02/in-picrture-5-768x432.jpg 768w, https://grasslandtimes.com/wp-content/uploads/2019/02/in-picrture-5.jpg 976w" sizes="(max-width: 300px) 100vw, 300px"><img class="alignnone size-medium wp-image-2474" src="https://grasslandtimes.com/wp-content/uploads/2019/02/In-pictur-1-300x169.jpg" alt="" width="300" height="169" srcset="https://grasslandtimes.com/wp-content/uploads/2019/02/In-pictur-1-300x169.jpg 300w, https://grasslandtimes.com/wp-content/uploads/2019/02/In-pictur-1-768x432.jpg 768w, https://grasslandtimes.com/wp-content/uploads/2019/02/In-pictur-1.jpg 976w" sizes="(max-width: 300px) 100vw, 300px"><img class="alignnone size-medium wp-image-2475" src="https://grasslandtimes.com/wp-content/uploads/2019/02/in-picture-4-300x169.jpg" alt="" width="300" height="169" srcset="https://grasslandtimes.com/wp-content/uploads/2019/02/in-picture-4-300x169.jpg 300w, https://grasslandtimes.com/wp-content/uploads/2019/02/in-picture-4-768x432.jpg 768w, https://grasslandtimes.com/wp-content/uploads/2019/02/in-picture-4.jpg 976w" sizes="(max-width: 300px) 100vw, 300px"><img class="alignnone size-medium wp-image-2470" src="https://grasslandtimes.com/wp-content/uploads/2019/02/In-pictures-300x169.jpg" alt="" width="300" height="169" srcset="https://grasslandtimes.com/wp-content/uploads/2019/02/In-pictures-300x169.jpg 300w, https://grasslandtimes.com/wp-content/uploads/2019/02/In-pictures-768x432.jpg 768w, https://grasslandtimes.com/wp-content/uploads/2019/02/In-pictures.jpg 976w" sizes="(max-width: 300px) 100vw, 300px"><img class="alignnone size-medium wp-image-2469" src="https://grasslandtimes.com/wp-content/uploads/2019/02/in-pictures-3-300x169.jpg" alt="" width="300" height="169" srcset="https://grasslandtimes.com/wp-content/uploads/2019/02/in-pictures-3-300x169.jpg 300w, https://grasslandtimes.com/wp-content/uploads/2019/02/in-pictures-3-768x432.jpg 768w, https://grasslandtimes.com/wp-content/uploads/2019/02/in-pictures-3.jpg 976w" sizes="(max-width: 300px) 100vw, 300px"></p>
<input type="hidden" id="share_width" value=""><input type="hidden" id="wwm_mode" value=""><div class="wp-post-author-wrap wp-post-author-shortcode left">
                    <h3 class="awpa-title"></h3>
                                        
        <div class="wp-post-author">

                <div class="awpa-img awpa-author-block square">
                    <a href="https://grasslandtimes.com/author/authoramy/"><img width="150" height="150" src="https://grasslandtimes.com/wp-content/uploads/2018/07/Screen-Shot-2017-04-26-at-8.06.29-AM-e1507316787401-150x150.png" class="avatar avatar-150 photo" alt="" srcset="https://grasslandtimes.com/wp-content/uploads/2018/07/Screen-Shot-2017-04-26-at-8.06.29-AM-e1507316787401-150x150.png 150w, https://grasslandtimes.com/wp-content/uploads/2018/07/Screen-Shot-2017-04-26-at-8.06.29-AM-e1507316787401-24x24.png 24w, https://grasslandtimes.com/wp-content/uploads/2018/07/Screen-Shot-2017-04-26-at-8.06.29-AM-e1507316787401-48x48.png 48w, https://grasslandtimes.com/wp-content/uploads/2018/07/Screen-Shot-2017-04-26-at-8.06.29-AM-e1507316787401-96x96.png 96w" sizes="(max-width: 150px) 100vw, 150px"></a>
                </div>
                <div class="wp-post-author-meta awpa-author-block">
                    <h4 class="awpa-display-name">
                        <a href="https://grasslandtimes.com/author/authoramy/">Amy J Madison</a>
                    </h4>

                    
                    
                                        <div class="wp-post-author-meta-bio">
                        <p>Amy is journalist who has been working in different countries. She puts light on latest world trends and serve as an analyst</p>
                    </div>
                    <div class="wp-post-author-meta-more-posts">
                        <p class="awpa-more-posts">                        
                           <a href="https://grasslandtimes.com/author/authoramy/" class="awpa-more-posts">See author's posts</a>
                        </p>
                    </div>
                                    </div>
        </div>

                                            </div>
                <div class="swp_social_panel swp_horizontal_panel  swp_flat_fresh  swp_default_full_color swp_individual_full_color swp_other_full_color  scale-100  scale-" data-min-width="1100" data-float-color="#ffffff" data-float="bottom" data-float-mobile="" style=""><div class="nc_tweetContainer swp_facebook" data-network="facebook"><a rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fgrasslandtimes.com%2Frodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir%2F2461%2F" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fgrasslandtimes.com%2Frodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir%2F2461%2F" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_twitter" data-network="twitter"><a rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=Rodrigo+Duterte+and+Kim+Jong-un+impersonators+cause+a+stir&amp;url=https%3A%2F%2Fgrasslandtimes.com%2Frodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir%2F2461%2F" data-link="https://twitter.com/intent/tweet?text=Rodrigo+Duterte+and+Kim+Jong-un+impersonators+cause+a+stir&amp;url=https%3A%2F%2Fgrasslandtimes.com%2Frodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir%2F2461%2F" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_google_plus" data-network="google_plus"><a rel="nofollow noreferrer noopener" target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fgrasslandtimes.com%2Frodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir%2F2461%2F" data-link="https://plus.google.com/share?url=https%3A%2F%2Fgrasslandtimes.com%2Frodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir%2F2461%2F" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_google_plus_icon"></i><span class="swp_share">+1</span></span></span></span></a></div><div class="nc_tweetContainer swp_linkedin" data-network="linkedin"><a rel="nofollow noreferrer noopener" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fgrasslandtimes.com%2Frodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir%2F2461%2F" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fgrasslandtimes.com%2Frodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir%2F2461%2F" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_linkedin_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_pinterest" data-network="pinterest"><a rel="nofollow noreferrer noopener" class="nc_tweet noPop" onclick="var e=document.createElement('script');
						   e.setAttribute('type','text/javascript');
						   e.setAttribute('charset','UTF-8');
						   e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);
						   document.body.appendChild(e);
						"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_pinterest_icon"></i><span class="swp_share">Pin</span></span></span></span></a></div><div class="nc_tweetContainer total_shares total_sharesalt"><span class="swp_count ">0 <span class="swp_label">Shares</span></span></div></div><div class="swp-content-locator"></div>
                    </div><!-- .entry-content -->

            <footer class="entry-footer">
        <div class="mb--footer-tags">
            <span class="tags-links item-metadata post-category-label"><span class="item-tablecell">Tagged in :</span> <span="post-category-label"> <a href="https://grasslandtimes.com/tag/kim-jong-un/" rel="tag">Kim Jong-un</a> <a href="https://grasslandtimes.com/tag/korea/" rel="tag">korea</a> <a href="https://grasslandtimes.com/tag/rodrigo-duterte/" rel="tag">Rodrigo Duterte</a></span></span>        </div>
        <div class="mb-footer-categories">
            <span class="item-metadata post-category-label"><span class="item-tablecell">Categorized in :</span> <span="post-category-label"> <a href="https://grasslandtimes.com/category/world-news/" rel="category tag">World News</a></span></span>        </div>
    </footer><!-- .entry-footer -->
    </article><!-- #post-## -->

	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://grasslandtimes.com/maroon-5-slammed-performance-cop-out-by-colin-kaepernicks-attorney/2468/" rel="prev">Maroon 5 Slammed performance &#8216;cop-out&#8217; by Colin Kaepernick&#8217;s attorney</a></div><div class="nav-next"><a href="https://grasslandtimes.com/save-yourself-from-choking-with-this-trick/2462/" rel="next">Save Yourself from Choking with This Trick</a></div></div>
	</nav><div id="comments" class="comments-area">
    	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/rodrigo-duterte-and-kim-jong-un-impersonators-cause-a-stir/2461/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://grasslandtimes.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='2461' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>			</form>
			</div><!-- #respond -->
	</div><!-- #comments -->
        </main><!-- #main -->
    </div><!-- #primary -->


<aside id="secondary" class="widget-area" role="complementary">
    <div id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://grasslandtimes.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div><div id="text-2" class="widget widget_text">			<div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- bo in post --><br />
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-3908513305207951"
     data-ad-slot="2872983825"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
		</div><div id="recent-posts-widget-with-thumbnails-2" class="widget recent-posts-widget-with-thumbnails"><div id="rpwwt-recent-posts-widget-with-thumbnails-2" class="rpwwt-widget">
	<h2 class="widget-title secondary-font">Recent News</h2>	<ul>
			<li><a href="https://grasslandtimes.com/marketing-scheme-gets-trump-family-sued-again/2466/"><img width="100" height="100" src="https://grasslandtimes.com/wp-content/uploads/2019/02/Marketing-Scheme-Gets-Trump-Family-Sued-Again-150x150.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="Trump" srcset="https://grasslandtimes.com/wp-content/uploads/2019/02/Marketing-Scheme-Gets-Trump-Family-Sued-Again-150x150.jpg 150w, https://grasslandtimes.com/wp-content/uploads/2019/02/Marketing-Scheme-Gets-Trump-Family-Sued-Again-24x24.jpg 24w, https://grasslandtimes.com/wp-content/uploads/2019/02/Marketing-Scheme-Gets-Trump-Family-Sued-Again-48x48.jpg 48w, https://grasslandtimes.com/wp-content/uploads/2019/02/Marketing-Scheme-Gets-Trump-Family-Sued-Again-96x96.jpg 96w" sizes="(max-width: 100px) 100vw, 100px" /><span class="rpwwt-post-title">Marketing Scheme Gets Trump Family Sued Again</span></a></li>
			<li><a href="https://grasslandtimes.com/3750-more-troops-sent-to-mexico-border-by-pentagon/2465/"><img width="100" height="100" src="https://grasslandtimes.com/wp-content/uploads/2019/02/3750-More-Troops-Sent-To-Mexico-Border-by-Pentagon-150x150.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="3,750 More Troops Sent To Mexico Border by Pentagon" srcset="https://grasslandtimes.com/wp-content/uploads/2019/02/3750-More-Troops-Sent-To-Mexico-Border-by-Pentagon-150x150.jpg 150w, https://grasslandtimes.com/wp-content/uploads/2019/02/3750-More-Troops-Sent-To-Mexico-Border-by-Pentagon-24x24.jpg 24w, https://grasslandtimes.com/wp-content/uploads/2019/02/3750-More-Troops-Sent-To-Mexico-Border-by-Pentagon-48x48.jpg 48w, https://grasslandtimes.com/wp-content/uploads/2019/02/3750-More-Troops-Sent-To-Mexico-Border-by-Pentagon-96x96.jpg 96w" sizes="(max-width: 100px) 100vw, 100px" /><span class="rpwwt-post-title">3,750 More Troops Sent To Mexico Border by Pentagon</span></a></li>
			<li><a href="https://grasslandtimes.com/nissans-choice-for-new-x-trail-car-is-japan-instead-of-uk/2464/"><img width="100" height="100" src="https://grasslandtimes.com/wp-content/uploads/2019/02/Nissans-Choice-For-New-X-Trail-Car-is-Japan-instead-of-UK-150x150.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="Nissan X Trial Car" srcset="https://grasslandtimes.com/wp-content/uploads/2019/02/Nissans-Choice-For-New-X-Trail-Car-is-Japan-instead-of-UK-150x150.jpg 150w, https://grasslandtimes.com/wp-content/uploads/2019/02/Nissans-Choice-For-New-X-Trail-Car-is-Japan-instead-of-UK-24x24.jpg 24w, https://grasslandtimes.com/wp-content/uploads/2019/02/Nissans-Choice-For-New-X-Trail-Car-is-Japan-instead-of-UK-48x48.jpg 48w, https://grasslandtimes.com/wp-content/uploads/2019/02/Nissans-Choice-For-New-X-Trail-Car-is-Japan-instead-of-UK-96x96.jpg 96w" sizes="(max-width: 100px) 100vw, 100px" /><span class="rpwwt-post-title">Nissan&#8217;s Choice For New X-Trail Car is Japan instead of UK</span></a></li>
			<li><a href="https://grasslandtimes.com/avocado-pits-being-converted-biodegradable-plastic-by-mexican-company/2463/"><img width="100" height="100" src="https://grasslandtimes.com/wp-content/uploads/2019/02/Avocado-pits-Being-Converted-Biodegradable-Plastic-by-Mexican-Company-150x150.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="Avocado pits Being Converted Biodegradable Plastic by Mexican Company" srcset="https://grasslandtimes.com/wp-content/uploads/2019/02/Avocado-pits-Being-Converted-Biodegradable-Plastic-by-Mexican-Company-150x150.jpg 150w, https://grasslandtimes.com/wp-content/uploads/2019/02/Avocado-pits-Being-Converted-Biodegradable-Plastic-by-Mexican-Company-24x24.jpg 24w, https://grasslandtimes.com/wp-content/uploads/2019/02/Avocado-pits-Being-Converted-Biodegradable-Plastic-by-Mexican-Company-48x48.jpg 48w, https://grasslandtimes.com/wp-content/uploads/2019/02/Avocado-pits-Being-Converted-Biodegradable-Plastic-by-Mexican-Company-96x96.jpg 96w" sizes="(max-width: 100px) 100vw, 100px" /><span class="rpwwt-post-title">Avocado pits Being Converted Biodegradable Plastic by Mexican Company</span></a></li>
			<li><a href="https://grasslandtimes.com/save-yourself-from-choking-with-this-trick/2462/"><img width="100" height="100" src="https://grasslandtimes.com/wp-content/uploads/2019/02/Save-Yourself-When-You-Are-Alone-from-Choking-with-This-Trick-150x150.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="Save Yourself from Choking with This Trick" srcset="https://grasslandtimes.com/wp-content/uploads/2019/02/Save-Yourself-When-You-Are-Alone-from-Choking-with-This-Trick-150x150.jpg 150w, https://grasslandtimes.com/wp-content/uploads/2019/02/Save-Yourself-When-You-Are-Alone-from-Choking-with-This-Trick-24x24.jpg 24w, https://grasslandtimes.com/wp-content/uploads/2019/02/Save-Yourself-When-You-Are-Alone-from-Choking-with-This-Trick-48x48.jpg 48w, https://grasslandtimes.com/wp-content/uploads/2019/02/Save-Yourself-When-You-Are-Alone-from-Choking-with-This-Trick-96x96.jpg 96w" sizes="(max-width: 100px) 100vw, 100px" /><span class="rpwwt-post-title">Save Yourself from Choking with This Trick</span></a></li>
		</ul>
</div><!-- .rpwwt-widget -->
</div><div id="swp_popular_posts_widget-2" class="widget widget_swp_popular_posts_widget"><div class="widget-text swp_widget_box" style="background:transparent;"><h2 class="widget-title secondary-font"><span class="widgettitle widget-title swp_popular_posts_title" style="">Popular Posts</span></h2><div class="swp_popular_post"><a href="https://grasslandtimes.com/maine-mendoza-and-arjo-atayde-are-exclusively-dating-official-now/2396/"><img style="width:100px;height:100px;" class="swp_pop_thumb" src="https://grasslandtimes.com/wp-content/uploads/2019/01/Maine-Mendoza-And-Arjo-Atayde-150x150.jpg" title="Maine Mendoza And Arjo Atayde Are Exclusively Dating: Official now" alt="Maine Mendoza And Arjo Atayde Are Exclusively Dating: Official now" nopin="nopin" /></a><a style="font-size:100%;" class="swp_popularity" href="https://grasslandtimes.com/maine-mendoza-and-arjo-atayde-are-exclusively-dating-official-now/2396/"><b>Maine Mendoza And Arjo Atayde Are Exclusively Dating: Official now</b><span class="swp_pop_count">761 Total Shares</span></a></div><div class="swp_clearfix"></div><div class="swp_popular_post"><a href="https://grasslandtimes.com/james-ingram-dies-at-66-grammy-winning-chart-topping-rb-singer/2445/"><img style="width:100px;height:100px;" class="swp_pop_thumb" src="https://grasslandtimes.com/wp-content/uploads/2019/02/James-Ingram-150x150.jpg" title="James Ingram ,Dies at 66, Grammy-Winning &#038; Chart-Topping R&#038;B Singer," alt="James Ingram ,Dies at 66, Grammy-Winning &#038; Chart-Topping R&#038;B Singer," nopin="nopin" /></a><a style="font-size:100%;" class="swp_popularity" href="https://grasslandtimes.com/james-ingram-dies-at-66-grammy-winning-chart-topping-rb-singer/2445/"><b>James Ingram ,Dies at 66, Grammy-Winning &#038; Chart-Topping R&#038;B Singer,</b><span class="swp_pop_count">39 Total Shares</span></a></div><div class="swp_clearfix"></div><div class="swp_popular_post"><a href="https://grasslandtimes.com/avocado-pits-being-converted-biodegradable-plastic-by-mexican-company/2463/"><img style="width:100px;height:100px;" class="swp_pop_thumb" src="https://grasslandtimes.com/wp-content/uploads/2019/02/Avocado-pits-Being-Converted-Biodegradable-Plastic-by-Mexican-Company-150x150.jpg" title="Avocado pits Being Converted Biodegradable Plastic by Mexican Company" alt="Avocado pits Being Converted Biodegradable Plastic by Mexican Company" nopin="nopin" /></a><a style="font-size:100%;" class="swp_popularity" href="https://grasslandtimes.com/avocado-pits-being-converted-biodegradable-plastic-by-mexican-company/2463/"><b>Avocado pits Being Converted Biodegradable Plastic by Mexican Company</b><span class="swp_pop_count">27 Total Shares</span></a></div><div class="swp_clearfix"></div><div class="swp_popular_post"><a href="https://grasslandtimes.com/branson-hard-brexit-will-bankrupt-uk/2155/"><img style="width:100px;height:100px;" class="swp_pop_thumb" src="https://grasslandtimes.com/wp-content/uploads/2019/01/richard-branson-150x150.jpg" title="Sir Richard Branson Says Brexit May Leave UK Bankrupted" alt="Sir Richard Branson Says Brexit May Leave UK Bankrupted" nopin="nopin" /></a><a style="font-size:100%;" class="swp_popularity" href="https://grasslandtimes.com/branson-hard-brexit-will-bankrupt-uk/2155/"><b>Sir Richard Branson Says Brexit May Leave UK Bankrupted</b><span class="swp_pop_count">8 Total Shares</span></a></div><div class="swp_clearfix"></div><div class="swp_popular_post"><a href="https://grasslandtimes.com/jacksonville-business-journal/431/"><img style="width:100px;height:100px;" class="swp_pop_thumb" src="https://grasslandtimes.com/wp-content/uploads/2018/07/veteranapuer-150x150.jpg" title="Vets 22 Chairman Jeff Shuford Featured in Jacksonville Business Journal Cover Story" alt="Vets 22 Chairman Jeff Shuford Featured in Jacksonville Business Journal Cover Story" nopin="nopin" /></a><a style="font-size:100%;" class="swp_popularity" href="https://grasslandtimes.com/jacksonville-business-journal/431/"><b>Vets 22 Chairman Jeff Shuford Featured in Jacksonville Business Journal Cover Story</b><span class="swp_pop_count">8 Total Shares</span></a></div><div class="swp_clearfix"></div><div class="swp_popular_post"><a href="https://grasslandtimes.com/mourning-orca/563/"><img style="width:100px;height:100px;" class="swp_pop_thumb" src="https://grasslandtimes.com/wp-content/uploads/2018/07/mourning-orca-mom-carried-her-dead-baby-for-days-through-the-ocean-150x150.jpg" title="Mourning Orca mom carried her &#8220;dead baby&#8221; for days through the ocean" alt="Mourning Orca mom carried her &#8220;dead baby&#8221; for days through the ocean" nopin="nopin" /></a><a style="font-size:100%;" class="swp_popularity" href="https://grasslandtimes.com/mourning-orca/563/"><b>Mourning Orca mom carried her &#8220;dead baby&#8221; for days through the ocean</b><span class="swp_pop_count">7 Total Shares</span></a></div><div class="swp_clearfix"></div><div class="swp_popular_post"><a href="https://grasslandtimes.com/maymay-entrata-invited-to-casting-call-for-arab-fashion-week/1847/"><img style="width:100px;height:100px;" class="swp_pop_thumb" src="https://grasslandtimes.com/wp-content/uploads/2018/11/Maymay-Entrata-150x150.jpg" title="Maymay Entrata, the first Filipina to get an invitation to walk at Arab Fashion week" alt="Maymay Entrata, the first Filipina to get an invitation to walk at Arab Fashion week" nopin="nopin" /></a><a style="font-size:100%;" class="swp_popularity" href="https://grasslandtimes.com/maymay-entrata-invited-to-casting-call-for-arab-fashion-week/1847/"><b>Maymay Entrata, the first Filipina to get an invitation to walk at Arab Fashion week</b><span class="swp_pop_count">6 Total Shares</span></a></div><div class="swp_clearfix"></div><div class="swp_popular_post"><a href="https://grasslandtimes.com/dad-makes-app-that-freezes-kids-phones-until-they-answer-your-texts/2220/"><img style="width:100px;height:100px;" class="swp_pop_thumb" src="https://grasslandtimes.com/wp-content/uploads/2019/01/Dad-makes-app-to-freeze-child-phone-1-150x150.jpg" title="Dad makes App that freezes  kids&#8217; phones until they answer your texts" alt="Dad makes App that freezes  kids&#8217; phones until they answer your texts" nopin="nopin" /></a><a style="font-size:100%;" class="swp_popularity" href="https://grasslandtimes.com/dad-makes-app-that-freezes-kids-phones-until-they-answer-your-texts/2220/"><b>Dad makes App that freezes  kids&#8217; phones until they answer your texts</b><span class="swp_pop_count">6 Total Shares</span></a></div><div class="swp_clearfix"></div><div class="swp_popular_post"><a href="https://grasslandtimes.com/nine-must-watch-films-this-july/198/"><img style="width:100px;height:100px;" class="swp_pop_thumb" src="https://grasslandtimes.com/wp-content/uploads/2018/07/Top-Chart-Nine-Must-Watch-Films-this-July-150x150.jpg" title="Nine Must Watch Films this July" alt="Nine Must Watch Films this July" nopin="nopin" /></a><a style="font-size:100%;" class="swp_popularity" href="https://grasslandtimes.com/nine-must-watch-films-this-july/198/"><b>Nine Must Watch Films this July</b><span class="swp_pop_count">4 Total Shares</span></a></div><div class="swp_clearfix"></div><div class="swp_popular_post"><a href="https://grasslandtimes.com/chester-zoo-fire-killed-animals/2124/"><img style="width:100px;height:100px;" class="swp_pop_thumb" src="https://grasslandtimes.com/wp-content/uploads/2018/12/Chester-Zoo-Fire-150x150.jpg" title="Chester Zoo Fire Killed Animals, Supporters Raist £100,000" alt="Chester Zoo Fire Killed Animals, Supporters Raist £100,000" nopin="nopin" /></a><a style="font-size:100%;" class="swp_popularity" href="https://grasslandtimes.com/chester-zoo-fire-killed-animals/2124/"><b>Chester Zoo Fire Killed Animals, Supporters Raist £100,000</b><span class="swp_pop_count">4 Total Shares</span></a></div><div class="swp_clearfix"></div></div></div>		<div id="recent-posts-1" class="widget widget_recent_entries">		<h2 class="widget-title secondary-font">Recent Posts</h2>		<ul>
											<li>
					<a href="https://grasslandtimes.com/marketing-scheme-gets-trump-family-sued-again/2466/">Marketing Scheme Gets Trump Family Sued Again</a>
									</li>
											<li>
					<a href="https://grasslandtimes.com/3750-more-troops-sent-to-mexico-border-by-pentagon/2465/">3,750 More Troops Sent To Mexico Border by Pentagon</a>
									</li>
											<li>
					<a href="https://grasslandtimes.com/nissans-choice-for-new-x-trail-car-is-japan-instead-of-uk/2464/">Nissan&#8217;s Choice For New X-Trail Car is Japan instead of UK</a>
									</li>
											<li>
					<a href="https://grasslandtimes.com/avocado-pits-being-converted-biodegradable-plastic-by-mexican-company/2463/">Avocado pits Being Converted Biodegradable Plastic by Mexican Company</a>
									</li>
											<li>
					<a href="https://grasslandtimes.com/save-yourself-from-choking-with-this-trick/2462/">Save Yourself from Choking with This Trick</a>
									</li>
					</ul>
		</div><div id="media_video-1" class="widget widget_media_video"><h2 class="widget-title secondary-font">Video</h2><div style="width:100%;" class="wp-video"><!--[if lt IE 9]><script>document.createElement('video');</script><![endif]-->
<video class="wp-video-shortcode" id="video-2461-1" preload="metadata" controls="controls"><source type="video/vimeo" src="https://vimeo.com/91495981?loop=0&#038;_=1" /><a href="https://vimeo.com/91495981?loop=0">https://vimeo.com/91495981?loop=0</a></video></div></div><div id="search-4" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://grasslandtimes.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div><div id="tag_cloud-1" class="widget widget_tag_cloud"><h2 class="widget-title secondary-font">Categories Cloud</h2><div class="tagcloud"><a href="https://grasslandtimes.com/category/breaking-news/" class="tag-cloud-link tag-link-12 tag-link-position-1" style="font-size: 22pt;" aria-label="Breaking News (126 items)">Breaking News<span class="tag-link-count"> (126)</span></a>
<a href="https://grasslandtimes.com/category/business/" class="tag-cloud-link tag-link-1 tag-link-position-2" style="font-size: 19.433333333333pt;" aria-label="Business (58 items)">Business<span class="tag-link-count"> (58)</span></a>
<a href="https://grasslandtimes.com/category/celebrity/" class="tag-cloud-link tag-link-10 tag-link-position-3" style="font-size: 20.055555555556pt;" aria-label="Celebrity (69 items)">Celebrity<span class="tag-link-count"> (69)</span></a>
<a href="https://grasslandtimes.com/category/cricket/" class="tag-cloud-link tag-link-13 tag-link-position-4" style="font-size: 9.4pt;" aria-label="Cricket (2 items)">Cricket<span class="tag-link-count"> (2)</span></a>
<a href="https://grasslandtimes.com/category/entertainment/" class="tag-cloud-link tag-link-9 tag-link-position-5" style="font-size: 21.066666666667pt;" aria-label="Entertainment (94 items)">Entertainment<span class="tag-link-count"> (94)</span></a>
<a href="https://grasslandtimes.com/category/fashion/" class="tag-cloud-link tag-link-6 tag-link-position-6" style="font-size: 11.733333333333pt;" aria-label="Fashion (5 items)">Fashion<span class="tag-link-count"> (5)</span></a>
<a href="https://grasslandtimes.com/category/finance/" class="tag-cloud-link tag-link-3 tag-link-position-7" style="font-size: 11.733333333333pt;" aria-label="Finance (5 items)">Finance<span class="tag-link-count"> (5)</span></a>
<a href="https://grasslandtimes.com/category/food/" class="tag-cloud-link tag-link-5 tag-link-position-8" style="font-size: 12.277777777778pt;" aria-label="Food (6 items)">Food<span class="tag-link-count"> (6)</span></a>
<a href="https://grasslandtimes.com/category/health-fitness/" class="tag-cloud-link tag-link-4 tag-link-position-9" style="font-size: 17.022222222222pt;" aria-label="Health &amp; Fitness (28 items)">Health &amp; Fitness<span class="tag-link-count"> (28)</span></a>
<a href="https://grasslandtimes.com/category/home-improvement/" class="tag-cloud-link tag-link-608 tag-link-position-10" style="font-size: 8pt;" aria-label="Home Improvement (1 item)">Home Improvement<span class="tag-link-count"> (1)</span></a>
<a href="https://grasslandtimes.com/category/life-style/" class="tag-cloud-link tag-link-147 tag-link-position-11" style="font-size: 12.666666666667pt;" aria-label="Life style (7 items)">Life style<span class="tag-link-count"> (7)</span></a>
<a href="https://grasslandtimes.com/category/marketing/" class="tag-cloud-link tag-link-15 tag-link-position-12" style="font-size: 11.733333333333pt;" aria-label="Marketing (5 items)">Marketing<span class="tag-link-count"> (5)</span></a>
<a href="https://grasslandtimes.com/category/music/" class="tag-cloud-link tag-link-149 tag-link-position-13" style="font-size: 11.111111111111pt;" aria-label="Music (4 items)">Music<span class="tag-link-count"> (4)</span></a>
<a href="https://grasslandtimes.com/category/politics/" class="tag-cloud-link tag-link-18 tag-link-position-14" style="font-size: 19.2pt;" aria-label="Politics (54 items)">Politics<span class="tag-link-count"> (54)</span></a>
<a href="https://grasslandtimes.com/category/sports/" class="tag-cloud-link tag-link-7 tag-link-position-15" style="font-size: 17.411111111111pt;" aria-label="Sports (31 items)">Sports<span class="tag-link-count"> (31)</span></a>
<a href="https://grasslandtimes.com/category/tech/" class="tag-cloud-link tag-link-2 tag-link-position-16" style="font-size: 17.255555555556pt;" aria-label="Tech (30 items)">Tech<span class="tag-link-count"> (30)</span></a>
<a href="https://grasslandtimes.com/category/travel-tourism/" class="tag-cloud-link tag-link-11 tag-link-position-17" style="font-size: 14.611111111111pt;" aria-label="Travel &amp; Tourism (13 items)">Travel &amp; Tourism<span class="tag-link-count"> (13)</span></a>
<a href="https://grasslandtimes.com/category/world-news/" class="tag-cloud-link tag-link-8 tag-link-position-18" style="font-size: 21.922222222222pt;" aria-label="World News (121 items)">World News<span class="tag-link-count"> (121)</span></a></div>
</div></aside><!-- #secondary -->
</div><!-- #content -->
<footer id="colophon" class="site-footer" role="contentinfo">
    
    <div class="footer-bottom">
        <div class="container">
            <div class="row row-table">
                <div class="col-md-4 col-sm-12 col-xs-12">
                    <div class="tm-social-share">
                                                <div class="social-icons ">
                            <div class="menu-main-menu-container"><ul id="social-menu" class=""><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1695"><a href="https://grasslandtimes.com/blog/"><span class="screen-reader-text">Blog</span></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1696"><a href="https://grasslandtimes.com/contact/"><span class="screen-reader-text">Contact Us</span></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1697"><a href="https://grasslandtimes.com/privacy-policy/"><span class="screen-reader-text">Privacy Policy</span></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1698"><a href="https://grasslandtimes.com/submit-news/"><span class="screen-reader-text">Submit News</span></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1699"><a href="https://grasslandtimes.com/terms-and-conditions/"><span class="screen-reader-text">Terms and Conditions</span></a></li>
</ul></div>
                            <span aria-hidden="true" class="stretchy-nav-bg secondary-bgcolor"></span>
                        </div>
                    </div>
                </div>
                <div class="col-md-4 col-sm-12 col-xs-12">
                    <div class="footer-logo text-center">
                            <span class="site-title secondary-font">
                                <a href="https://grasslandtimes.com/" rel="home">
                                    Grassland Times                                </a>
                            </span>
                                                    <p class="site-description">Daily Times</p>
                                            </div>
                </div>
                <div class="col-md-4 col-sm-12 col-xs-12">
                    <div class="site-copyright text-right">
                        Copyright All right reserved                        <br>
                    </div>
                </div>
            </div>
        </div>
    </div>
</footer>
</div><!-- #page -->
<a id="scroll-up" class="secondary-bgcolor"><i class="ion-ios-arrow-up"></i></a>
	<div style="display:none">
	<div class="grofile-hash-map-c3537cf31a9a43d8a4ad9878e26b8246">
	</div>
	</div>
<link rel='stylesheet' id='mediaelement-css'  href='https://grasslandtimes.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.6-78496d1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://grasslandtimes.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=4.9.9' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/grasslandtimes.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://grasslandtimes.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.0.5'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201906'></script>
<script type='text/javascript' src='https://grasslandtimes.com/wp-content/plugins/social-warfare/assets/js/script.min.js?ver=3.3.3'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://grasslandtimes.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.9'></script>
<script type='text/javascript' src='https://grasslandtimes.com/wp-content/themes/perfect-magazine/assets/libraries/js/navigation.js?ver=20151215'></script>
<script type='text/javascript' src='https://grasslandtimes.com/wp-content/themes/perfect-magazine/assets/libraries/js/skip-link-focus-fix.js?ver=20151215'></script>
<script type='text/javascript' src='https://grasslandtimes.com/wp-content/themes/perfect-magazine/assets/libraries/slick/js/slick.min.js?ver=4.9.9'></script>
<script type='text/javascript' src='https://grasslandtimes.com/wp-content/themes/perfect-magazine/assets/libraries/bootstrap/js/bootstrap.min.js?ver=4.9.9'></script>
<script type='text/javascript' src='https://grasslandtimes.com/wp-content/themes/perfect-magazine/assets/libraries/magnific-popup/jquery.magnific-popup.min.js?ver=4.9.9'></script>
<script type='text/javascript' src='https://grasslandtimes.com/wp-content/themes/perfect-magazine/assets/libraries/jquery-match-height/jquery.matchHeight.min.js?ver=4.9.9'></script>
<script type='text/javascript' src='https://grasslandtimes.com/wp-content/themes/perfect-magazine/assets/libraries/custom/js/custom-script.js?ver=4.9.9'></script>
<script type='text/javascript' src='https://grasslandtimes.com/wp-content/themes/newsliner/assets/js/child-script.js?ver=4.9.9'></script>
<script type='text/javascript' src='https://grasslandtimes.com/wp-includes/js/wp-embed.min.js?ver=4.9.9'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://grasslandtimes.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.6-78496d1'></script>
<script type='text/javascript' src='https://grasslandtimes.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=4.9.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://grasslandtimes.com/wp-includes/js/mediaelement/renderers/vimeo.min.js?ver=4.2.6-78496d1'></script>
<script type='text/javascript' src='https://grasslandtimes.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=4.9.9'></script>
<script type="text/javascript">var swpFloatBeforeContent = false;var swpClickTracking = false;</script><script type='text/javascript' src='https://stats.wp.com/e-201906.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.6.1',blog:'143381442',post:'2461',tz:'0',srv:'grasslandtimes.com'} ]);
	_stq.push([ 'clickTrackerInit', '143381442', '2461' ]);
</script>

</body>
</html>